Minecraft 1.9.4 Resource Packs

Pokebox – A Pixelmon Resource Pack is an interesting mod that is worth playing, specially if you are a fan of the Pokemon series. It is generated to
Compatible: 1.10, 1.9.4, 1.9, 1.8.9, 1.7.10
Updated: September 22, 2016
Never Cleaner Resource Pack is a simple and cartoonish resource pack that work in progress! The goal of texture pack is help you to relax when playing
Compatible: 1.10.2, 1.9.4
Updated: September 18, 2016
Realistic Adventure World Enhancement project Resource Pack – A project with a goal to make Minecraft as realistic as possible. This can look de
Compatible: 1.10.2, 1.9.4
Updated: September 18, 2016
This is Dishonored Resource pack – a themed texture pack for minecraft! Enter the steampunk world created by Arkane Studios, and add minecraft!
Compatible: 1.10.2, 1.9.4
Updated: September 18, 2016
Screenshots Greener This pack is much more colorful than defaults toned down color scheme Smooth Wood Wood still looks very much like default except I
Compatible: 1.10.2, 1.9.4
Updated: August 9, 2016
Serinity HD resource packs feature some of the best-looking visuals you can find in Minecraft. The high resolutions allow for far more detail than is
Compatible: 1.10.2, 1.10, 1.9.4, 1.9, 1.8.9, 1.7.10
Updated: August 6, 2016
This texture pack requires MCPatcher or Optifine to utilize features such as Connected Textures, Randomobs, BetterSkys, and more. Excalibur is a resou
Compatible: 1.10.2, 1.9.4
Updated: August 5, 2016
About Simplistic Heaven Pack Simplistic heaven is a texturepack I’ve been working for for a couple of days. As of now, it contains the textures
Compatible: 1.9.4, 1.8.9, 1.7.10, 1.7.2
Updated: July 17, 2016
The Ancient World Resource Pack is without a doubt one of the absolute best texture packs of its kind available today. The pack has actually been arou
Compatible: 1.10.2, 1.10, 1.9.4, 1.9, 1.8.9, 1.7.10
Updated: July 17, 2016
Although its name implies otherwise, The Galaxy Resource Pack isn’t a sci-fi themed creation but it is definitely a texture pack that you should
Compatible: 1.10.2, 1.10, 1.9.4, 1.9, 1.8.9, 1.7.10
Updated: July 17, 2016