Minecraft 1.8.9 Resource Packs

Woodcraft resource pack is now available for Minecraft v1.9! This pack offers an immersive wood-grained experience. Most textures have been modified,
Compatible: 1.10, 1.9.4, 1.9, 1.8.9, 1.7.10
Updated: June 20, 2016
Sassgaard – Cartoony Norse Resource Pack add a slightly bonkers look to your Minecraft. In a sea of pseudo-photo-realistic resource packs comes
Compatible: 1.10, 1.9.4, 1.9, 1.8.9, 1.7.10
Updated: June 20, 2016
Screenshots How to install Fights of Cydonia Resource Pack? Download the Resource Pack. Open Minecraft, and go to Options->Resource Packs->
Compatible: 1.10, 1.9.4, 1.9, 1.8.9, 1.7.10
Updated: June 20, 2016
Reality’s Reverie resource pack is a 32x/16x Semi-Realism Light – Fantasy 1.8 | 1.9 | 1.10 Snapshot Pack. Yet tries to keep hold of Minecr
Compatible: 1.10, 1.9.4, 1.9, 1.8.9, 1.7.10
Updated: June 20, 2016
Dancing Life resource pack is a 16x texture pack that strives to bring life with only a very small canvas. All textures, with the exception of the fon
Compatible: 1.10, 1.9.4, 1.9, 1.8.9, 1.7.10
Updated: June 20, 2016
Good day ladies and gentlenerds! If you like simple resourcepacks you should maybe give this one a try. How to install k44du2’s Simpleton Resour
Compatible: 1.10, 1.9.4, 1.9, 1.8.9, 1.7.10
Updated: June 20, 2016
Model Basalt pack works with the default Minecraft resource pack. It also works with texture-packs that display they support this pack. If you use it
Compatible: 1.10, 1.9.4, 1.9, 1.8.9, 1.7.10
Updated: June 20, 2016
Glitch’s 3D Addons Pack for Minecraft 1.8.9 and 1.9. This 3d models pack will make your world feeling a little bit nicer. How to insta
Compatible: 1.10, 1.9.4, 1.9, 1.8.9, 1.7.10
Updated: June 20, 2016
About Zori’s 3D Weapons Pack This is the first version of Zori’s 3D Weapons Pack. Every weapon is fully modeled in 3D, for added
Compatible: 1.10, 1.9.4, 1.9, 1.8.9, 1.7.10
Updated: June 20, 2016
About Pixelmon’s Faithful 32x Addon Pack You still need to download the vanilla faithful 32×32 pack, because it is not included. Fait
Compatible: 1.10, 1.9.4, 1.9, 1.8.9, 1.7.10
Updated: June 20, 2016