Minecraft 1.9.4 Mods

With thousands minecraft 1.9.4 mods: latest mods, updated regularly mods, most popular mods. You can find and download any minecraft mods 1.9.4 at here.

Armory Mod 1.12.2/1.10.2 provides you with all your armoring dreams. It will allow you to make armor as you want, not only the strength of the armor c
Compatible: 1.12.2, 1.10.2
Updated: June 18, 2018
BowScope Mod 1.12.2/1.11.2 will make you can bow shot precisely in the distance. This mod create for see player is behind block at you can’t see
Compatible: 1.12.2, 1.11.2
Updated: June 1, 2018
CD4017BE Library 1.12.2/1.11.2 is a java library that is used by CD4017BE’s mods: Inductive Automation, Inductive Logistics and Automated Redsto
Updated: June 1, 2018
One Piece Craft Mod 1.12.2/1.10.2 combines the Anime One Piece and Minecraft. This mod adds weapons, food and other stuff from the One Piece. Features
Compatible: 1.12.2, 1.10.2
Updated: May 21, 2018
Advanced XRay Mod 1.12.2/1.11.2 is not a standard XRay mod. It won’t make all or most of the blocks around you disappear making it difficult to
Compatible: 1.12.2, 1.11.2
Updated: May 2, 2018
Bone Torch Mod 1.12.2/1.11.2 is a simple mod that adds bone torches to Minecraft. It’s for when your stuck deep in a cavern and you are out of t
Compatible: 1.12.2, 1.11.2
Updated: May 2, 2018
VE-FluidHandling Mod 1.12.2/1.11.2 is an independent library from VoltzEngine to provide shared access to fluid prefabs. This includes a few fluids, f
Compatible: 1.12.2, 1.11.2
Updated: May 2, 2018
It’s the Little Things Mod 1.12.2/1.11.2 adds small features you didn’t know you needed. Features: Allows you to make the Modpack yell at
Compatible: 1.12.2, 1.11.2
Updated: May 2, 2018
New CreativeTabs and White Laptop 1.12.2! It ads some random Stuff to Minecraft! Not making it useless or Sci-Fi, but so that it will fit into Minecra
Compatible: 1.12.2, 1.10.2, 1.9.4, 1.9, 1.8, 1.7.10
Updated: April 8, 2018
Realistic Item Drops Mod 1.12.2 is a simple mod that will give a very different feeling to your Minecraft experience. Auto-pickup can be disabled requ
Compatible: 1.12.2, 1.12, 1.11.2, 1.10.2, 1.9.4
Updated: April 8, 2018