Minecraft 1.8.9 Mods

With thousands minecraft 1.8.9 mods: latest mods, updated regularly mods, most popular mods. You can find and download any minecraft mods 1.8.9 at here.

Backlytra Mod backports Elytra from Minecraft 1.9.2 to Minecraft  1.8.9, 1.7.10, and 1.9. Supports vanilla resource packs to override texture and sou
Compatible: 1.9, 1.8.9, 1.7.10
Updated: May 25, 2016
The Lizzy Anvil mod adds a new anvil to Minecraft: the workshop anvil (a.k.a. The Lizzy Anvil). The workshop anvil replaces the vanilla anvil for the
Compatible: 1.8.9
Updated: May 25, 2016
Ores of Chemical Elements Mod adds some chemical elements such as Bor or Tungsten. These elements in the form of the ores under the ground. All have H
Compatible: 1.8.9
Updated: May 25, 2016
Entity Explorer Mod enables users to watch entities through walls. Open the gui by pressing I key and find out id of entity you want to by pressing K
Compatible: 1.8.9
Updated: May 25, 2016
Storage Silo Mod gives plenties of storage (999 stacks) all from a single block having a GUI similar to the ME Terminal of the Applied Energistics 2 m
Compatible: 1.9, 1.8.9, 1.8, 1.7.10
Updated: May 25, 2016
Not Enough Potions Mod providing formulas for the Potion Core potions also adds a mortar and pestle and a combinung cauldron block to produce new poti
Compatible: 1.8.9
Updated: May 25, 2016
rp_Talismans-2-Mod.jpg
Talismans 2 Mod is a sequel to Talismans known as fantastic mod in minecraft. It currently removes Thaumcraft/Bloodmagic/Botania Support because of n
Compatible: 1.8.9, 1.8, 1.7.10
Updated: May 24, 2016
Repose Mod launchs walkable soil slopes and more to Minecraft. This mod allows player walk up gentle slopes of grass, sand…without continuous j
Compatible: 1.8.9, 1.7.10
Updated: May 23, 2016
Just Enough Tooltips Mod is an exceedingly useful mod in Minecraft and also considered as a gift for those interesting in food and cooking which is an
Compatible: 1.9, 1.8.9
Updated: May 17, 2016
More-Nature-Mod
Animals Plus Mod Introduction: Has travelling the Minecraft worlds gotten a tad stale for you? A lack of unique creatures, maybe? If so, Animals+ not
Compatible: 1.9, 1.8.9, 1.8, 1.7.10, 1.7.2, 1.6.4
Updated: May 16, 2016